crudlet.org

Home > Ubuntu Unable > Ubuntu Unable To Locate Package Postgresql-9.3

Ubuntu Unable To Locate Package Postgresql-9.3

Gentux referenced this issue in Nanocloud/community May 11, 2016 Merged Fix travis tests by upgrading postgres version from 9.4 to 9.5 #559 quarterdome commented May 12, 2016 Now that Heroku made more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Science Can cheese in hand luggage be mistaken for plastic explosive? You can either install 9.3 instead, which is in Trusty, or you can use the directions here: https://wiki.postgresql.org/wiki/Apt to enable the PostgreSQL Apt repository for Trusty. http://crudlet.org/ubuntu-unable/ubuntu-unable-to-locate-package-phpmyadmin.html

django/djangoproject.com#727 Open PostgreSQL 9.6, 9.5 orocrm/doctrine-extensions#30 Sign up for free to join this conversation on GitHub. For Postgres we actually have a tool installed locally on the VMs which makes it easier to install different versions, and for 9.4 and 9.5 there is extra work required. Unfortunately, the only environment that supports 9.5 is the trusty distribution using sudo. Please, start communicate properly. click resources

sudo apt-get install postgresql-9.2 Reading package lists... Browse other questions tagged ubuntu postgresql or ask your own question. Member joshk commented Aug 24, 2016 Hi @c2h5oh I completely agree that this has taken too long on our end, and that communication has not been fluid or transparent. Why wouldn't it be available? –Michael Jun 8 '13 at 14:58 add a comment| 2 Answers 2 active oldest votes up vote 19 down vote accepted In Ubuntu official repositories only

Enabling this for now to ensure that the tests pass with 9.5 available, can revert back if there are better alternatives. sudo add-apt-repository "deb https://apt.postgresql.org/pub/repos/apt/ trusty-pgdg main" Update and Install PostgreSQL 9.4: sudo apt-get update sudo apt-get install postgresql-9.4 Default postgres super user and postgres database is created. cancel complete The Anti-Santa: Dealing with the Naughty List What are Iron nuggets and what can they be used for? To use postgresql-9.2.3 in Ubuntu, you need to compile it yourself.

How to respond to a ridiculous request from a senior colleague? Design strategy to replace multiple if else What exactly does the anonymous JavaScript function f => f do? This may end up working for us, however due to the additional time required to provision sudo environments, as well as the size / run duration of our test suites, we'd pg_upgrade permalinkembedsaveparentgive gold[–]rocketmonkey44 1 point2 points3 points 1 year ago(0 children)As everyone has mentioned, it's a fairly new release so it will take a little time to get into the repos.

Building dependency tree... Unfortunately, the only environment that supports 9.5 is the trusty distribution using sudo. permalinkembedsavegive gold[–]bojanco 1 point2 points3 points 1 year ago(0 children)As others mentioned, 9.4 is new and not in the Ubuntu repository yet. https://docs.travis-ci.com/user/database-setup/#MySQL-5.6 https://github.com/travis-ci/docs-travis-ci-com/issues/396#issuecomment-156507245 Removing notifications to stop spamming people while I try to get this working.">Update Travis CI config to use Postgres 9.5 … The UPSERT feature that is used by several

before_install: - sudo /etc/init.d/postgresql stop - wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add - - sudo sh -c 'echo "deb http://apt.postgresql.org/pub/repos/apt/ precise-pgdg main 9.5" >> /etc/apt/sources.list.d/postgresql.list' - sudo apt-get I want to become a living god! This is an important milestone for Node.js + PostgreSQL, now that all DB frameworks can follow up. @MariadeAnton thank you for the steps you provided! Why is Titanic's Astor asking if Jack is from the Boston Dawsons? “muss” with an object Does advantage negate disadvantage (for things such as sneak attack)?

and he installed 9.1), I did the following sudo apt-get install postgresql-9.2.3 Reading package lists... http://crudlet.org/ubuntu-unable/ubuntu-unable-to-locate-package-eclipse.html Full disk problem on Ubuntu 16.04 (Xenial Xerus) Is a Windows XP virtual machine with no network connection safe from hacking? Done Building dependency tree Reading state information... https://github.com/travis-ci/travis-ci/issues/4264 https://docs.travis-ci.com/user/database-setup/#Using-a-different-PostgreSQL-Version Also, MySQL is no longer available as a service.

What does HR do for me? These are smaller repositories for a few packages that ubuntu community people package up as the need arises. Let's speed that file sentence searching program Interview question "How long will you stay with us?" Does "Excuse him." make sense? this contact form Linked 96 Why don't the Ubuntu repositories have the latest versions of software? 64 “Unable to locate package” while trying to install packages with APT Related 3I'm trying to install postgresql

Are the mountains surrounding Mordor natural? Resolving deltas: 100% (332/332), done. Also visit askubuntu.com/q/378558 –Pandya May 22 '15 at 9:59 add a comment| 2 Answers 2 active oldest votes up vote 4 down vote accepted That is because in Ubuntu 14.04 repositories

I've tried similar attempts as above, but then I get could not connect to database postgres: FATAL: role "travis" does not exist This is what I had tried (thoroughly removing other

BanzaiMan reopened this Aug 19, 2016 vitaly-t referenced this issue in brianc/node-postgres Aug 19, 2016 Merged Upgrading tests to PostgreSQL 9.5 #1114 vitaly-t commented Aug 19, 2016 • edited To increase Log In Sign Up Report a Bug Use this form to report bugs related to the Community Report a bug: Name Email Message Sign in Try it free Apps Websites Build Reply to this email directly, view it on GitHub #4264 (comment), or mute the thread https://github.com/notifications/unsubscribe-auth/AAAh_RSdFJ0144e-mfRCP_OF8rVx3CHzks5qizO1gaJpZM4FWL_X . 👍 3 c2h5oh commented Aug 24, 2016 @joshk I'm glad to hear it, up vote 32 down vote favorite 9 I just installeed Postgres, but it seems to have installed 9.3 and I'd like to start with 9.4 I simply did apt-get install postgresql

If you like, I can update this issue once I know some further information. Minimum font size for mobile view Let's speed that file sentence searching program Does advantage negate disadvantage (for things such as sneak attack)? Hot Network Questions A Page of Puzzling What exactly does the anonymous JavaScript function f => f do? http://crudlet.org/ubuntu-unable/ubuntu-unable-to-locate-package-mercurial.html We are a customer, at the premium level of service.

One of your paying customer (through my employer). 👍 7 MariadeAnton referenced this issue in travis-ci/docs-travis-ci-com Aug 18, 2016 Closed Update PostgreSQL version installed by default #696 cllns commented Aug Related 2Unable to install python2.7-dev due to unmet dependencies Ubuntu 12.042Ubuntu 12.04/14.04 - apt-get 404 Not Found [IP: local-dns-server-ip 80] through proxy0Ubuntu apt-get install -f fails because package on server is pkieltyka commented May 27, 2016 yea.. I agree with you completely that we could have done better.

asked 2 years ago viewed 4828 times active 3 months ago Blog Stack Overflow Gives Back 2016 Developers, Webmasters, and Ninjas: What’s in a Job Title? asked 3 years ago viewed 11180 times active 2 years ago Blog Stack Overflow Gives Back 2016 Developers, Webmasters, and Ninjas: What’s in a Job Title? Related to travis-ci/travis-ci#4264">Install PostgreSQL 9.5 … With this change, the installation of PostgreSQL 9.5 (beta2) is already possible, but `postgresql-9.5-postgis-2.1` package will be available only after 9.5.0 final release comes out. jasonmp85 Jason Petersen GPG key ID: 9F1D3510D110ABA9 Learn about signing commits 13d2ee7 freesteph commented Nov 10, 2015 I had to tweak my travis.yml file quite a few times before

TBH, as a customer, once PG9.6 hits, if we can test it, we will be moving to another service. — You are receiving this because you are subscribed to this thread. I figure with a simple shell script it'd be easy to divine what the most recent minor version for a given Postgres major version is, so you'll automatically be running the I'll say it again - we love Travis! You signed in with another tab or window.

However, it needs a caveat that PostGIS may not be available. Output the sign Are the mountains surrounding Mordor natural? Reference taken from this Article: First, check the version of Ubuntu: lsb_release -sc You need to add the latest PostgreSQL repository for the latest version, otherwise It will install PostgreSQL 9.3. Reply Log In to Comment 0 handyremstad June 8, 2013 Digging a bit further I belive there is a ppa for you here: http://askubuntu.com/questions/186610/how-do-i-upgrade-to-postgres-9-2 Reply Log In to Comment Have another

How do I move ahead? 15.04 share|improve this question edited Jun 10 '15 at 7:22 krt 752311 asked Jun 10 '15 at 6:32 Daman 1 add a comment| 1 Answer 1 Done E: Unable to locate package postgresql-9.5-postgis E: Couldn't find any package by regex 'postgresql-9.5-postgis' BanzaiMan self-assigned this Jul 13, 2015 grooverdan referenced this issue in travis-ci/travis-build Jul 25, 2015 Open Why wouldn't the part of the Earth facing the Sun a half year before be facing away from it now at noon?

Border